blob: 3b2a7dafd702a39a29d11a63efffbeaf19969803 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="b05e4a6b92b2cfe608b6cd8d5d37168680fc080e"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "8e460b4319aa509e57ba887ac56806030aa85ccd" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk bootstat .gn"
PLATFORM_SUBDIR="bootstat"
inherit cros-workon platform
DESCRIPTION="Chrome OS Boot Time Statistics Utilities"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/bootstat/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND="
sys-apps/rootdev:=
"
RDEPEND="
${COMMON_DEPEND}
"
DEPEND="
${COMMON_DEPEND}
"
src_install() {
dosbin "${OUT}"/bootstat
dosbin bootstat_archive
dosbin bootstat_get_last
dobin bootstat_summary
dolib.so "${OUT}"/lib/libbootstat.so
insinto /usr/include/metrics
doins bootstat.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/libbootstat_unittests"
}