blob: 662d72c49d593c4fb7c7dff0ff68b1bd906e1faa [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest
DESCRIPTION="shill autotests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~*"
# Enable autotest by default.
IUSE="+autotest +tpm tpm2"
RDEPEND="
!<chromeos-base/autotest-tests-0.0.3
chromeos-base/shill-test-scripts
"
DEPEND="${RDEPEND}"
IUSE_TESTS="
+tests_network_DhcpClasslessStaticRoute
+tests_network_DhcpFailureWithStaticIP
+tests_network_DhcpNak
+tests_network_DhcpNegotiationSuccess
+tests_network_DhcpNegotiationTimeout
+tests_network_DhcpNonAsciiParameter
+tests_network_DhcpRenew
+tests_network_DhcpRenewWithOptionSubset
+tests_network_DhcpRequestHostName
+tests_network_DhcpStaticIP
+tests_network_DhcpVendorEncapsulatedOptions
+tests_network_DhcpWpadNegotiation
+tests_network_WiFiInvalidParameters
+tests_network_WiFiResume
+tests_network_WlanPresent
+tests_network_WlanRegulatory
+tests_network_WlanHasIP
tpm? ( +tests_network_VPNConnect )
tpm2? ( +tests_network_VPNConnect )
"
IUSE="${IUSE} ${IUSE_TESTS}"
AUTOTEST_FILE_MASK="*.a *.tar.bz2 *.tbz2 *.tgz *.tar.gz"