blob: da6c7eaa9c868a6e54668dc784ee9e2d8ddf783a [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit cros-constants
DESCRIPTION="Client portion of autotest installed at image creation time"
HOMEPAGE="http://src.chromium.org"
LICENSE="BSD"
SLOT="0"
KEYWORDS="*"
IUSE="-moblab"
DEPEND="
chromeos-base/autotest
"
S=${WORKDIR}
src_install() {
AUTOTEST_INSTALL_DIR="/usr/local/autotest"
use moblab && AUTOTEST_INSTALL_DIR="/usr/local/autodir"
dodir "${AUTOTEST_INSTALL_DIR}"
tar xvf "${SYSROOT}/${AUTOTEST_BASE}/packages/client-autotest.tar.bz2" \
-C "${D}/${AUTOTEST_INSTALL_DIR}" || die
}