| # Copyright 2018 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI="7" |
| |
| CROS_WORKON_COMMIT="1118066f7067322a4d0f2f8f708ae17e1b6fe400" |
| CROS_WORKON_TREE=("5f078a2eb960dbcc4347e114f6f6c4c4e946917e" "1e3a238a4fbe3762df99ba7ad42134b0fb1074aa" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk chromeos-common-script .gn" |
| |
| PLATFORM_SUBDIR="chromeos-common-script" |
| WANT_LIBCHROME="no" |
| WANT_LIBBRILLO="no" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Chrome OS storage info tools" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/chromeos-common-script/" |
| SRC_URI="" |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="direncryption fsverity prjquota" |
| |
| src_install() { |
| platform_src_install |
| |
| insinto /usr/share/misc |
| doins share/chromeos-common.sh |
| doins share/lvm-utils.sh |
| if use direncryption; then |
| sed -i '/local direncryption_enabled=/s/false/true/' \ |
| "${D}/usr/share/misc/chromeos-common.sh" || |
| die "Can not set directory encryption in common library" |
| fi |
| if use fsverity; then |
| sed -i '/local fsverity_enabled=/s/false/true/' \ |
| "${D}/usr/share/misc/chromeos-common.sh" || |
| die "Can not set fs-verity in common library" |
| fi |
| if use prjquota; then |
| sed -i '/local prjquota_enabled=/s/false/true/' \ |
| "${D}/usr/share/misc/chromeos-common.sh" || |
| die "Can not set project quota in common library" |
| fi |
| } |