| # Copyright 2015 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="10b13f4ee9f713f646450da83ba6ccb261873349" |
| CROS_WORKON_TREE=("a2cce5470dac5262b88bb59c5132c911a2aa4bd2" "adc370fe7782687faa5297f0e97a9d893deac26b" "f5b9b06147bd01a8dee984b7bf2037b6a099c038" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk power_manager/client power_manager/dbus_bindings .gn" |
| |
| PLATFORM_NATIVE_TEST="yes" |
| PLATFORM_SUBDIR="power_manager/client" |
| WANT_LIBCHROME="no" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Power manager DBus client library for Chromium OS" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/power_manager/" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| # Disable unittesting for client bindings. |
| RESTRICT="test" |
| |
| BDEPEND=" |
| chromeos-base/chromeos-dbus-bindings |
| " |
| |
| # Workaround to rebuild this package on the chromeos-dbus-bindings update. |
| # Please find the comment in chromeos-dbus-bindings for its background. |
| DEPEND=" |
| chromeos-base/chromeos-dbus-bindings:= |
| " |
| |
| RDEPEND="" |
| |
| src_install() { |
| platform_src_install |
| |
| # Install DBus client library. |
| platform_install_dbus_client_lib "power_manager" |
| } |