blob: 7d70e901cbc9487ddd2cf8097e4da21692e38a4d [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT=("22fdd6134ccd014ab7caca0d1e53c0dac317121d" "d44b27636e66c840a6dc604ca23aa64aba0df60b")
CROS_WORKON_TREE=("c2a55bbd521007dda665079cf4999d32673bbd84" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6" "308701ef2e27faef2b2bfaae31720a81f1816330")
CROS_WORKON_LOCALNAME=("platform2" "aosp/system/update_engine")
CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/system/update_engine")
CROS_WORKON_EGIT_BRANCH=("main" "master")
CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/update_engine")
CROS_WORKON_USE_VCSID=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE=("common-mk .gn" "")
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="update_engine/client-headers"
inherit cros-debug cros-workon platform
DESCRIPTION="Chrome OS Update Engine client library"
HOMEPAGE="https://chromium.googlesource.com/aosp/platform/system/update_engine/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND="
!<chromeos-base/update_engine-0.0.3
"
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "update_engine"
}