| # Copyright 2020 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_LOCALNAME=("../platform2" "../aosp/external/libutf") |
| CROS_WORKON_PROJECT=("chromiumos/platform2" "aosp/platform/external/libutf") |
| CROS_WORKON_EGIT_BRANCH=("main" "master") |
| CROS_WORKON_DESTDIR=("${S}/platform2" "${S}/platform2/libutf") |
| CROS_WORKON_SUBTREE=("common-mk .gn" "") |
| |
| PLATFORM_SUBDIR="libutf" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="A UTF-8 library based on the AOSP version of libutf." |
| HOMEPAGE="https://chromium.googlesource.com/aosp/platform/external/libutf/" |
| |
| LICENSE="MIT" |
| SLOT="0" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| RDEPEND="" |
| DEPEND="" |
| |
| src_install() { |
| platform_src_install |
| |
| insinto "/usr/include/android/" |
| doins "${S}/utf.h" |
| |
| dolib.a "${OUT}/libutf.a" |
| } |