blob: db19c37ec3bda6e20f901bd6781623b07903ce69 [file] [log] [blame]
# Copyright 2015 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d5c94c56c6a4cddc010fc05d43f8b45636756994"
CROS_WORKON_TREE=("766eb02843d4aa0c62648193fed7b5f7311b90fe" "21353c7389a1a16f9a62a4b7968859f618df9e86" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk power_manager .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="power_manager/client"
inherit cros-workon platform
DESCRIPTION="Power manager DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/power_manager/"
LICENSE="BSD-Google"
KEYWORDS="*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
# Workaround to rebuild this package on the chromeos-dbus-bindings update.
# Please find the comment in chromeos-dbus-bindings for its background.
DEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
RDEPEND=""
src_install() {
platform_src_install
# Install DBus client library.
platform_install_dbus_client_lib "power_manager"
}