| # Copyright 2017 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=5 |
| |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="../platform2" |
| # TODO(crbug.com/809389): Avoid directly including headers from other packages. |
| CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/hal/usb camera/include camera/mojo chromeos-config common-mk" |
| CROS_WORKON_OUTOFTREE_BUILD="1" |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| |
| PLATFORM_SUBDIR="camera/hal/usb" |
| |
| inherit cros-camera cros-workon platform |
| |
| DESCRIPTION="Chrome OS USB camera HAL v3." |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="~*" |
| |
| RDEPEND=" |
| chromeos-base/cros-camera-android-deps |
| chromeos-base/cros-camera-libs |
| dev-libs/re2 |
| media-libs/libsync |
| chromeos-base/chromeos-config-tools" |
| |
| DEPEND="${RDEPEND} |
| media-libs/libyuv |
| virtual/pkgconfig" |
| |
| src_install() { |
| platform_src_install |
| cros-camera_dohal "${OUT}/lib/libcamera_hal.so" usb.so |
| } |
| |
| platform_pkg_test() { |
| local tests=( |
| image_processor_test |
| ) |
| local test_bin |
| for test_bin in "${tests[@]}"; do |
| platform_test run "${OUT}/${test_bin}" |
| done |
| } |