| # Copyright 2021 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_PROJECT="chromiumos/platform/dev-util" |
| CROS_WORKON_LOCALNAME=("../platform/dev") |
| CROS_WORKON_SUBTREE="src/chromiumos/test/dut" |
| |
| inherit cros-go cros-workon |
| |
| DESCRIPTION="DUT Service Server implementation for interfacing with the DUT" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/dut" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| IUSE="" |
| |
| CROS_GO_WORKSPACE=( |
| "${S}" |
| ) |
| |
| CROS_GO_BINARIES=( |
| "chromiumos/test/dut/cmd/dutserver" |
| ) |
| |
| CROS_GO_TEST=( |
| "chromiumos/test/dut/cmd/dutserver/..." |
| ) |
| |
| CROS_GO_VET=( |
| "${CROS_GO_TEST[@]}" |
| ) |
| |
| DEPEND=" |
| dev-util/lro-server |
| dev-go/grpc |
| chromeos-base/cros-config-api |
| " |
| RDEPEND="${DEPEND}" |