| # Copyright 2021 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| CROS_WORKON_COMMIT="d5f4dc19a6af173932c7db54e1550aef00eb2f55" |
| CROS_WORKON_TREE="973d967f3987480fbaf6415e28a902e2956a3acd" |
| CROS_WORKON_PROJECT="chromiumos/platform/dev-util" |
| CROS_WORKON_LOCALNAME=("../platform/dev") |
| CROS_WORKON_SUBTREE="src/chromiumos/test/dut" |
| |
| inherit cros-go cros-workon |
| |
| DESCRIPTION="DUT Service Server implementation for interfacing with the DUT" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/dut" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| IUSE="" |
| |
| CROS_GO_WORKSPACE=( |
| "${S}" |
| ) |
| |
| CROS_GO_BINARIES=( |
| "chromiumos/test/dut/cmd/dutserver" |
| ) |
| |
| CROS_GO_TEST=( |
| "chromiumos/test/dut/cmd/dutserver/..." |
| ) |
| |
| CROS_GO_VET=( |
| "${CROS_GO_TEST[@]}" |
| ) |
| |
| DEPEND=" |
| dev-util/lro-server |
| dev-go/grpc |
| chromeos-base/cros-config-api |
| " |
| RDEPEND="${DEPEND}" |