blob: 0dd74cb4a7f9ed78c1ac1eb7d423099346de9552 [file] [log] [blame]
# Copyright 2021 The ChromiumOS Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="7915904d14896fadd3c4fc71079583b79770ae84"
CROS_WORKON_TREE=("379ddc8b0f80f69217eeef21aa4bbc1f4dfc77b6" "09223c9565cfeddc50300f068d28ed7083cff687" "2ca199cb0971c1771c028a010b0c03da9082cd39")
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME=("../platform/dev")
CROS_WORKON_SUBTREE="src/chromiumos/test/test_finder src/chromiumos/test/util src/chromiumos/test/execution"
inherit cros-go cros-workon
DESCRIPTION="Test finder for find tests that match the specified test suite tags"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/src/chromiumos/test/test_finder"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
CROS_GO_VERSION="${PF}"
CROS_GO_BINARIES=(
"chromiumos/test/test_finder/cmd/cros-test-finder"
)
CROS_GO_TEST=(
"chromiumos/test/test_finder/cmd/cros-test-finder/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
DEPEND="
chromeos-base/tast-cmd:=
chromeos-base/tast-proto
dev-util/cros-test
dev-util/lro-server
"
RDEPEND="${DEPEND}"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}