| # Copyright 2018 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2. |
| |
| EAPI=7 |
| |
| PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 ) |
| |
| inherit distutils-r1 |
| |
| DESCRIPTION="gRPC library for google-iam-v1" |
| SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" |
| |
| LICENSE="Apache-2.0" |
| SLOT="0" |
| KEYWORDS="*" |
| |
| RDEPEND=" |
| >=dev-python/google-api-core-1.19.0[${PYTHON_USEDEP}] |
| dev-python/googleapis-common-protos[${PYTHON_USEDEP}] |
| dev-python/protobuf-python[${PYTHON_USEDEP}] |
| dev-python/grpcio[${PYTHON_USEDEP}]" |
| DEPEND="${RDEPEND}" |