blob: f9468f4524427a22cc59155f595bec6c2c5fd33d [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6f9011123f3656c45bb34148673aa110a22326b3"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "49e3b5c529d012af19cb326eec9cf346538d4459" "318ca9f48604274cd31481e13eb9321be3d94d8f" "c37af7d99913a584dbfb1b64fdb83acb19e91c20" "049eedf136293a1ab81617017200cb31032eb384" "791c6808b4f4f5f1c484108d66ff958d65f8f1e3")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/tools/connector_client camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/tools/connector_client"
inherit cros-camera cros-workon platform
DESCRIPTION="A simple package that exercises cros-camera-libcamera_connector"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="chromeos-base/cros-camera-libs"
DEPEND="${RDEPEND}
x11-libs/libdrm"
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros_camera_connector_client"
}