| # Copyright 2021 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_LOCALNAME="../platform2" |
| # iioservice/ is included just to make sandbox happy when running `gn gen`. |
| CROS_WORKON_SUBTREE=".gn camera/build camera/features camera/include camera/gpu camera/common camera/mojo chromeos-config common-mk iioservice/libiioservice_ipc iioservice/mojo ml_core ml_core/mojo" |
| CROS_WORKON_OUTOFTREE_BUILD="1" |
| CROS_WORKON_INCREMENTAL_BUILD="1" |
| |
| PLATFORM_SUBDIR="camera/features/hdrnet/tests" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Chrome OS camera HDRnet integration tests" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="~*" |
| |
| # 'ipu6' and 'ipu6ep' are passed to and used in BUILD.gn files. |
| IUSE="ipu6 ipu6ep ipu6epmtl" |
| |
| BDEPEND="virtual/pkgconfig" |
| |
| RDEPEND=" |
| chromeos-base/cros-camera-android-deps:= |
| chromeos-base/cros-camera-libs:= |
| dev-cpp/benchmark:= |
| dev-cpp/gtest:= |
| media-libs/cros-camera-libfs:= |
| virtual/opengles:= |
| " |
| |
| DEPEND="${RDEPEND} |
| x11-drivers/opengles-headers:= |
| " |
| |
| src_configure() { |
| cros_optimize_package_for_speed |
| platform_src_configure |
| } |