blob: b59d2d57b9df60bb9d8655372fac467e0c2c23fa [file] [log] [blame]
#
# Copyright 2021 Google LLC
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# version 2 as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
EAPI=7
# The dev-go/gcp* packages are all built from this repo. They should
# be updated together.
CROS_GO_SOURCE="github.com/GoogleCloudPlatform/google-cloud-go:cloud.google.com/go v${PV}"
CROS_GO_PACKAGES=(
"cloud.google.com/go/storage"
)
CROS_GO_TEST=(
"${CROS_GO_PACKAGES[@]}"
)
inherit cros-go
DESCRIPTION="Google Cloud Client Libraries for Go"
HOMEPAGE="https://code.googlesource.com/gocloud"
SRC_URI="$(cros-go_src_uri)"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RESTRICT="binchecks strip"
DEPEND="
dev-go/cmp
dev-go/gcp-iam
dev-go/gapi-option
dev-go/gapi-transport
dev-go/gapi-storage
dev-go/gcp-internal
dev-go/genproto
dev-go/grpc
dev-go/net
"
RDEPEND="${DEPEND}"