blob: 439edb68d5a8ed32ea07481bb5ab06c053196b5b [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_RUST_REMOVE_DEV_DEPS=1
inherit cros-rust
DESCRIPTION="A hash table with consistent order and fast iteration.
The indexmap is a hash table where the iteration order of the key-value
pairs is independent of the hash values of the keys. It has the usual
hash table functionality, it preserves insertion order except after
removals, and it allows lookup of its elements by either hash table key
or numerical index. A corresponding hash set type is also provided.
This crate was initially published under the name ordermap, but it was renamed to
indexmap."
HOMEPAGE="https://crates.io/crates/indexmap"
SRC_URI="https://crates.io/api/v1/crates/${PN}/${PV}/download -> ${P}.crate"
LICENSE="|| ( Apache-2.0 MIT )"
SLOT="${PV}/${PR}"
KEYWORDS="*"
DEPEND="
>=dev-rust/hashbrown-0.9.1:= <dev-rust/hashbrown-0.10.0
=dev-rust/rayon-1*:=
=dev-rust/serde-1*:=
=dev-rust/autocfg-1*:=
"
RDEPEND="${DEPEND}"
# This file was automatically generated by cargo2ebuild.py