blob: b6f6bd814df0251188fdbec8b8ec58222fb3a4d0 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=6
CROS_WORKON_COMMIT="0553127ef2b660a5c71f12a9417ed4ad35f07120"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "a9708ef639f0f7929195d0f3921ebd1a12ad96bd" "460b5c588dbf96a4f62c05b2dd799de43949c37b" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk metrics mist .gn"
PLATFORM_SUBDIR="mist"
inherit cros-workon platform udev
DESCRIPTION="Chromium OS Modem Interface Switching Tool"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/mist/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
RDEPEND="
chromeos-base/libbrillo:=[udev]
>=chromeos-base/metrics-0.0.1-r3152
dev-libs/protobuf:=
net-dialup/ppp
virtual/libusb:1
virtual/udev
"
DEPEND="${RDEPEND}"
platform_pkg_test() {
platform_test "run" "${OUT}/mist_testrunner"
}
src_install() {
dobin "${OUT}"/mist
insinto /usr/share/mist
doins default.conf
udev_dorules 51-mist.rules
}