blob: ab73f2f2a2393fd365d17fa24dd1df7cf50761e4 [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="67f002ffc6f157b2d2c102d78f76b8ae8cc309d8"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "aa0612733aca2d5ffa65470f07408228b473ebdb" "5bcd4487aea45b91806e5db9af44e6b3d9290c13" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-config runtime_probe .gn"
PLATFORM_SUBDIR="runtime_probe"
inherit cros-workon platform
DESCRIPTION="Device component probe tool **for factory environment**."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/runtime_probe/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE="cros-debug generated_cros_config unibuild +factory_runtime_probe"
# TODO(yhong): Extract common parts with runtime_probe-9999.ebuild to a shared
# eclass.
COMMON_DEPEND="
unibuild? (
!generated_cros_config? ( chromeos-base/chromeos-config:= )
generated_cros_config? ( chromeos-base/chromeos-config-bsp:= )
)
chromeos-base/chromeos-config-tools:=
"
RDEPEND="
${COMMON_DEPEND}
chromeos-base/ec-utils
"
# Add vboot_reference as build time dependency to read cros_debug status
DEPEND="${COMMON_DEPEND}
chromeos-base/shill-client:=
chromeos-base/system_api:=
chromeos-base/vboot_reference:=
"
pkg_setup() {
cros-workon_pkg_setup
# Assert that the package is not "directly" installed into Chrome OS
# images. We currently only anticipate that files introduced by this
# package being used as the source materials for other packages.
if [[ "$(cros_target)" != "board_sysroot" ]]; then
die "${PN} should never be installed into Chrome OS images directly."
fi
}
src_install() {
dobin "${OUT}/factory_runtime_probe"
dobin "${OUT}/factory_runtime_probe_installer"
}