blob: d4219821f5e7048ad5e3945d4962586e89e6fe14 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk dlcservice .gn"
PLATFORM_SUBDIR="dlcservice/client"
inherit cros-workon platform
DESCRIPTION="DlcService D-Bus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/dlcservice/client"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="~*"
# D-Bus proxies generated by this client library depend on the code generator
# itself (chromeos-dbus-bindings) and produce header files that rely on
# libbrillo library.
DEPEND="
chromeos-base/chromeos-dbus-bindings
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "dlcservice"
}