blob: 18ca5d600bcbe1b5f3c975fe66bbda122303ee03 [file] [log] [blame]
# Copyright (c) 2012 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
CROS_WORKON_COMMIT="11821b983f1227bc86f29b3a67cf3be41d833795"
CROS_WORKON_TREE="0bcd941cfe6b3a9446ded078cab2e84fbab54ff8"
CROS_WORKON_PROJECT="chromiumos/platform/dev-util"
CROS_WORKON_LOCALNAME="dev"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="host"
inherit cros-workon
DESCRIPTION="Development utilities for ChromiumOS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/dev-util/+/HEAD/host/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="app-portage/gentoolkit
>=chromeos-base/devserver-0.0.2
dev-util/shflags
dev-util/toolchain-utils
"
# These are all either bash / python scripts. No actual builds DEPS.
DEPEND=""
src_compile() { :; }
src_install() {
dobin host/cros_workon_make
# Repo and git bash completion.
dosym /usr/share/bash-completion/completions/repo /etc/bash_completion.d/repo
dosym /usr/share/bash-completion/completions/git /etc/bash_completion.d/git
}