blob: bde0cf5450640784e0c5eefe985f414ddc2b21ce [file] [log] [blame]
# Copyright 2014 The Chromium Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="4"
DESCRIPTION="Install Chromium OS sshd Upstart file to a shared location."
HOMEPAGE="http://www.chromium.org/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
S="${WORKDIR}"
src_install() {
exeinto /usr/share/chromeos-ssh-config
doexe "${FILESDIR}"/sshd-pre
doexe "${FILESDIR}"/sshd-post
insinto /usr/lib/systemd/system/sshd.service.d
doins "${FILESDIR}"/chromeos-sshd.conf
insinto /usr/share/chromeos-ssh-config/init
doins "${FILESDIR}"/openssh-server.conf
insinto /etc/init
doins "${FILESDIR}"/openssh-server.conf.README
}