blob: 21204bcec996a14553fbeb990ef853147daa5a8c [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=7
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "3f9bd291ca1a611db3eaaff6cce78f4ebaa0c7eb" "fa823f91c6f2d1432f2bfaf49b5785eeb4e6e6fb" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk bootid-logger croslog .gn"
PLATFORM_SUBDIR="bootid-logger"
inherit cros-workon platform
DESCRIPTION="Program to record the current boot ID to the log"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/bootid-logger"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
RDEPEND="!<=chromeos-base/croslog-0.0.1-r44"
src_install() {
platform_install
insinto /etc/init
doins log-bootid-on-boot.conf
}
platform_pkg_test() {
platform test_all
}