blob: 17ded4a45cf3eb668f73c024bbb131a3c2c2acd6 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="6"
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "396263bc402f0a6170b30ba28fb6694fd2c0ad06" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk avtest_label_detect .gn"
inherit cros-sanitizers cros-workon cros-common.mk
DESCRIPTION="Autotest label detector for audio/video/camera"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/avtest_label_detect"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan v4l2_codec vaapi"
RDEPEND="vaapi? ( x11-libs/libva )"
DEPEND="${RDEPEND}"
src_unpack() {
cros-workon_src_unpack
S+="/avtest_label_detect"
}
src_configure() {
export USE_VAAPI=$(usex vaapi)
export USE_V4L2_CODEC=$(usex v4l2_codec)
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
# Install built tools
pushd "${OUT}" >/dev/null
dobin avtest_label_detect
popd >/dev/null
insinto /etc
doins "${S}"/avtest_label_detect.conf
}