| # Copyright 2015 The ChromiumOS Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT="480fbd6a415fa6e4ef522f8faff737257117e676" |
| CROS_WORKON_TREE=("6de787b958a72244a1b26f776bd715021684383f" "586d0c789a629ebd8759f584c7d7d7c03a4628f7" "f91b6afd5f2ae04ee9a2c19109a3a4a36f7659e6") |
| CROS_WORKON_INCREMENTAL_BUILD=1 |
| CROS_WORKON_LOCALNAME="platform2" |
| CROS_WORKON_PROJECT="chromiumos/platform2" |
| CROS_WORKON_OUTOFTREE_BUILD=1 |
| CROS_WORKON_SUBTREE="common-mk debugd .gn" |
| |
| PLATFORM_SUBDIR="debugd/client" |
| |
| inherit cros-workon platform |
| |
| DESCRIPTION="Chrome OS debugd client library" |
| HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/debugd/" |
| SRC_URI="" |
| |
| LICENSE="BSD-Google" |
| KEYWORDS="*" |
| |
| BDEPEND=" |
| chromeos-base/chromeos-dbus-bindings |
| " |
| |
| # Workaround to rebuild this package on the chromeos-dbus-bindings update. |
| # Please find the comment in chromeos-dbus-bindings for its background. |
| DEPEND=" |
| chromeos-base/chromeos-dbus-bindings:= |
| " |
| |
| src_install() { |
| platform_src_install |
| # Install DBus client library. |
| platform_install_dbus_client_lib "debugd" |
| } |