blob: 26c369d500e4e18fdc1d0cc3764c0b11a71351bf [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.6.9999
#hackport: flags: sse41:cpu_flags_x86_sse4_1,sse2:cpu_flags_x86_sse2,integer-gmp:gmp
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="A class for types that can be converted to a hash value"
HOMEPAGE="https://github.com/tibbe/hashable"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="*"
IUSE="+cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 test"
RDEPEND=">=dev-haskell/text-0.11.0.5:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( dev-haskell/hunit
>=dev-haskell/quickcheck-2.4.0.1
>=dev-haskell/random-1.0 <dev-haskell/random-1.2
>=dev-haskell/test-framework-0.3.3
dev-haskell/test-framework-hunit
>=dev-haskell/test-framework-quickcheck2-0.2.9 )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag cpu_flags_x86_sse2 sse2) \
$(cabal_flag cpu_flags_x86_sse4_1 sse41)
}