blob: e3784ce01f950a94cf796be01d7bc6bbf4c6d213 [file] [log] [blame]
# Copyright 2014 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI="6"
CROS_WORKON_COMMIT="e17d85021220d89f89a1db189358a8dcea232e8f"
CROS_WORKON_TREE=("52a8a8b6d3bbca5e90d4761aa308a5541d52b1bb" "34c95610bbb2e5b9e5a08f0ffc45a96171f940ff" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_DESTDIR="${S}"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk avtest_label_detect .gn"
inherit cros-sanitizers cros-workon cros-common.mk
DESCRIPTION="Autotest label detector for audio/video/camera"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/avtest_label_detect"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="-asan v4l2_codec vaapi"
RDEPEND="vaapi? ( x11-libs/libva )"
DEPEND="${RDEPEND}"
src_unpack() {
cros-workon_src_unpack
S+="/avtest_label_detect"
}
src_configure() {
export USE_VAAPI=$(usex vaapi)
export USE_V4L2_CODEC=$(usex v4l2_codec)
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
# Install built tools
pushd "${OUT}" >/dev/null
dobin avtest_label_detect
popd >/dev/null
insinto /etc
doins "${S}"/avtest_label_detect.conf
}