blob: 3874adb3394cf4e8e5abec296894e9633b9a24f8 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="../platform2"
CROS_WORKON_SUBTREE=".gn camera/build camera/common camera/include common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="camera/common/libcamera_connector_test"
inherit cros-camera cros-workon platform
DESCRIPTION="Chrome OS camera connector test."
LICENSE="BSD-Google"
KEYWORDS="~*"
RDEPEND="
chromeos-base/cros-camera-libs:=
dev-cpp/gtest:=
media-libs/libyuv
virtual/jpeg:0"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_install() {
platform_src_install
dobin "${OUT}/cros_camera_connector_test"
}