blob: 3ccc1a43454c21adb8921a7d44c13fcd5576d103 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk policy_utils .gn"
PLATFORM_SUBDIR="policy_utils"
inherit cros-workon platform
DESCRIPTION="Device-policy-management library and tool for Chrome OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/policy_utils/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="~*"
COMMON_DEPEND="
"
DEPEND="
${COMMON_DEPEND}
chromeos-base/system_api
"
RDEPEND="
${COMMON_DEPEND}
"
src_install() {
dosbin "${OUT}/policy"
}
platform_pkg_test() {
local tests=(
libmgmt_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test "run" "${OUT}/${test_bin}"
done
}