| # Copyright 2021 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| CROS_WORKON_COMMIT=("12d86fcd388d39eac1fb23988a2bc54d67cf09c7" "62a3049e9dbdaccda5cf7bce82bf7991cec9d371") |
| CROS_WORKON_TREE=("984c6b95246a821639541839c2029754912f2849" "791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb") |
| CROS_GO_PACKAGES=( |
| "chromiumos/perfetto/trace_processor/..." |
| ) |
| |
| inherit cros-constants |
| |
| CROS_WORKON_LOCALNAME=("aosp/external/perfetto" "platform2") |
| CROS_WORKON_PROJECT=("platform/external/perfetto" "chromiumos/platform2") |
| CROS_WORKON_REPO=("${CROS_GIT_AOSP_URL}" "${CROS_GIT_HOST_URL}") |
| CROS_WORKON_DESTDIR=("${S}/aosp/external/perfetto" "${S}/platform2") |
| CROS_WORKON_EGIT_BRANCH=("master" "main") |
| CROS_WORKON_SUBTREE=("" "common-mk .gn") |
| |
| PLATFORM_SUBDIR="./" |
| |
| inherit cros-go cros-workon platform |
| |
| DESCRIPTION="Perfetto go proto for Chrome OS" |
| HOMEPAGE="https://android.googlesource.com/platform/external/perfetto/+/refs/tags/v15.0/protos/perfetto/metrics/android/" |
| |
| KEYWORDS="*" |
| IUSE="cros-debug" |
| LICENSE="Apache-2.0" |
| SLOT="0" |
| |
| # protobuf dep is for using protoc at build-time to generate perfetto's headers. |
| BDEPEND=" |
| dev-go/protobuf |
| " |
| |
| src_unpack() { |
| platform_src_unpack |
| CROS_GO_WORKSPACE="${OUT}/gen/go" |
| } |
| |
| src_prepare() { |
| default |
| cp "${FILESDIR}/BUILD.gn" "${S}" |
| } |
| |
| src_install() { |
| cros-go_src_install |
| } |