blob: 22c39c433bcced13d6f3b5ded17ef7d684e5f70c [file] [log] [blame]
# Copyright (c) 2013 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="0553127ef2b660a5c71f12a9417ed4ad35f07120"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "a9708ef639f0f7929195d0f3921ebd1a12ad96bd" "4a45ea46c086c0a4b6eeff7eb1365097acd44641" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
# TODO(crbug.com/809389): Avoid directly including headers from other packages.
CROS_WORKON_SUBTREE="common-mk metrics p2p .gn"
PLATFORM_SUBDIR="p2p"
inherit cros-debug cros-workon platform user
DESCRIPTION="Chromium OS P2P"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/p2p/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
COMMON_DEPEND=">=chromeos-base/metrics-0.0.1-r3152:=
dev-libs/glib:=
net-dns/avahi-daemon:=
net-firewall/iptables:="
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
platform_pkg_test() {
local tests=(
p2p-client-unittests
p2p-server-unittests
p2p-http-server-unittests
p2p-common-unittests
)
local test_bin
cd "${OUT}"
for test_bin in "${tests[@]}"; do
platform_test "run" "./${test_bin}"
done
}
pkg_preinst() {
# Groups are managed in the central account database.
enewgroup p2p
enewuser p2p
}
src_install() {
dosbin "${OUT}"/p2p-client
dosbin "${OUT}"/p2p-server
dosbin "${OUT}"/p2p-http-server
insinto /etc/init
doins data/p2p.conf
# Install fuzzer
platform_fuzzer_install "${S}"/OWNERS \
"${OUT}"/p2p_http_server_fuzzer
}