blob: a1ab4b0be02f8721a4b9b915e6ad06cbcc0b5299 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk sirenia .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="sirenia/manatee-client"
inherit cros-workon platform
DESCRIPTION="Chrome OS ManaTEE D-Bus client library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/sirenia/"
LICENSE="BSD-Google"
KEYWORDS="~*"
BDEPEND="
chromeos-base/chromeos-dbus-bindings
"
src_install() {
# Install D-Bus client library.
platform_install_dbus_client_lib "manatee"
}