blob: 4a7663a6573ffef7e34e01fb6a104cf653b235ee [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
CROS_WORKON_COMMIT="0e103e3821ffbc575b67d6d9c426cac3ee4402b3"
CROS_WORKON_TREE="210df4cb14c4f7c420a697e85e6a7bec211d5bed"
CROS_WORKON_PROJECT="chromiumos/third_party/autotest"
CROS_WORKON_LOCALNAME="third_party/autotest/files"
inherit cros-workon autotest-deponly
DESCRIPTION="Autotest D-Bus deps"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/autotest/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
# Autotest enabled by default.
IUSE="+autotest"
AUTOTEST_DEPS_LIST="dbus_protos"
# NOTE: For deps, we need to keep *.a
AUTOTEST_FILE_MASK="*.tar.bz2 *.tbz2 *.tgz *.tar.gz"
DEPEND="chromeos-base/system_api
dev-libs/protobuf:=
"
# Calling this here, so tests using this dep don't have to call setup_dep().
src_prepare() {
autotest-deponly_src_prepare
}