blob: 967ed7e44ff3928d144da3f282cdff129fe985f5 [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="5c0fcf0f8725b98043a4b18f36e21489375d133a"
CROS_WORKON_TREE="3bb07f6afc46a008c0dc9d3ae3f64b9b3273004c"
CROS_WORKON_PROJECT="chromiumos/platform/vboot_reference"
inherit cros-workon autotest
DESCRIPTION="vboot tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/vboot_reference/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="*"
# Enable autotest by default.
IUSE="${IUSE} +autotest"
IUSE_TESTS="
+tests_firmware_VbootCrypto
"
IUSE="${IUSE} ${IUSE_TESTS}"
CROS_WORKON_LOCALNAME=platform/vboot_reference
# path from root of repo
AUTOTEST_CLIENT_SITE_TESTS=autotest/client
src_compile() {
# for Makefile
export VBOOT_SRC_DIR=${WORKDIR}/${P}
autotest_src_compile
}