blob: e444e57b348546e47fb2fadf98abe427c64042ab [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="e4d08848f7ee842b8cc7eef4b5ac40371eab0c5a"
CROS_WORKON_TREE="f962a7d69f70f98e292bc4a8161b165a1d3af867"
CROS_WORKON_PROJECT="chromiumos/platform/tast"
CROS_WORKON_LOCALNAME="platform/tast"
CROS_GO_BINARIES=(
"chromiumos/tast/cmd/remote_test_runner"
"chromiumos/tast/cmd/tast"
"chromiumos/tast/cmd/tast_rtd"
)
CROS_GO_VERSION="${PF}"
CROS_GO_TEST=(
"chromiumos/tast/cmd/remote_test_runner/..."
"chromiumos/tast/cmd/tast/..."
# Also test common code.
"chromiumos/tast/..."
)
CROS_GO_VET=(
"${CROS_GO_TEST[@]}"
)
inherit cros-go cros-workon
DESCRIPTION="Host executables for running integration tests"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform/tast/"
LICENSE="BSD-Google"
SLOT="0/0"
KEYWORDS="*"
IUSE=""
# Build-time dependencies should be added to tast-build-deps, not here.
DEPEND="chromeos-base/tast-build-deps:="
RDEPEND="
app-arch/tar
app-arch/xz-utils
chromeos-base/google-breakpad
chromeos-base/tast-build-deps
chromeos-base/tast-vars
net-misc/gsutil
!chromeos-base/tast-common
"
src_prepare() {
# Disable cgo and PIE on building Tast binaries. See:
# https://crbug.com/976196
# https://github.com/golang/go/issues/30986#issuecomment-475626018
export CGO_ENABLED=0
export GOPIE=0
default
}