blob: 6e36ca93235f2c3fdc59d99d24b8c39510030215 [file] [log] [blame]
# Copyright (c) 2011 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE="common-mk smogcheck .gn"
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_OUTOFTREE_BUILD="1"
inherit cros-common.mk cros-sanitizers cros-workon cros-debug
DESCRIPTION="TPM SmogCheck library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/smogcheck/"
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE="-asan"
src_unpack() {
cros-workon_src_unpack
S+="/smogcheck"
}
src_configure() {
sanitizers-setup-env
cros-common.mk_src_configure
}
src_install() {
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
}