blob: 203de0998d60f6c061f59c4a9cd92ce1cfca7b96 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="0553127ef2b660a5c71f12a9417ed4ad35f07120"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "4abc9fac8153750a03865f00a60126fc46c47d5f" "a9708ef639f0f7929195d0f3921ebd1a12ad96bd" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
# TODO(crbug.com/809389): remove 'metrics' pulled in from header dependency.
CROS_WORKON_SUBTREE="common-mk screen-capture-utils metrics .gn"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
PLATFORM_SUBDIR="screen-capture-utils"
inherit cros-workon platform
DESCRIPTION="Utilities for screen capturing"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/screen-capture-utils/"
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
# Mark the old screenshot package as blocker so it gets automatically removed in
# incremental builds.
RDEPEND="
chromeos-base/metrics
!chromeos-base/screenshot
media-libs/libpng:0=
media-libs/minigbm:=
net-libs/libvncserver
x11-libs/libdrm:=
virtual/opengles"
DEPEND="${RDEPEND}
x11-drivers/opengles-headers"
src_install() {
dosbin "${OUT}/kmsvnc"
dosbin "${OUT}/screenshot"
}