blob: 86abc553dcbcfe4386f48b1f8de326f094a429aa [file] [log] [blame]
# Copyright 2021 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="1af5e10724a3a74cd6fb7fae4e802f044d458f8d"
CROS_WORKON_TREE=("e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb" "bd22f6fa6d8ddce914d34c02064afe2f9e6abaf3" "791c6808b4f4f5f1c484108d66ff958d65f8f1e3")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_SUBTREE=".gn hps common-mk"
CROS_WORKON_OUTOFTREE_BUILD="1"
CROS_WORKON_INCREMENTAL_BUILD="1"
PLATFORM_SUBDIR="hps"
inherit cros-workon platform user
DESCRIPTION="Chrome OS HPS daemon."
LICENSE="BSD-Google"
KEYWORDS="*"
IUSE=""
RDEPEND="
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
dev-embedded/libftdi:=
"
pkg_preinst() {
enewuser "hpsd"
enewgroup "hpsd"
}
src_install() {
dosbin "${OUT}"/hpsd
# Install upstart configuration.
insinto /etc/init
doins daemon/init/*.conf
insinto /etc/dbus-1/system.d
doins daemon/dbus/org.chromium.Hps.conf
}
platform_pkg_test() {
local tests=(
dev_test
hps_test
)
local test_bin
for test_bin in "${tests[@]}"; do
platform_test run "${OUT}/${test_bin}"
done
}