blob: e6c1a22be76b8691d9826d62985a6be156d74ca4 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "1e7b7af56eebd756a7256d798a6d7680d470250d" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-common-script .gn"
PLATFORM_SUBDIR="chromeos-common-script"
inherit cros-workon platform
DESCRIPTION="Chrome OS storage info tools"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-common-script/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="direncryption fsverity kernel-3_18 kernel-4_4 prjquota"
REQUIRED_USE="prjquota? ( !kernel-4_4 !kernel-3_18 )"
src_install() {
insinto /usr/share/misc
doins share/chromeos-common.sh
doins share/lvm-utils.sh
if use direncryption; then
sed -i '/local direncryption_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set directory encryption in common library"
fi
if use fsverity; then
sed -i '/local fsverity_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set fs-verity in common library"
fi
if use prjquota; then
sed -i '/local prjquota_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set project quota in common library"
fi
}