blob: 5fd844b714971904ecddf55abcb725cbfb2873ef [file] [log] [blame]
# Copyright (c) 2010 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_DESTDIR="${S}/platform2"
CROS_WORKON_SUBTREE="common-mk bootstat .gn"
PLATFORM_SUBDIR="bootstat"
inherit cros-workon platform
DESCRIPTION="Chrome OS Boot Time Statistics Utilities"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/bootstat/"
SRC_URI=""
LICENSE="BSD-Google"
KEYWORDS="~*"
IUSE=""
COMMON_DEPEND="
sys-apps/rootdev:=
"
RDEPEND="
${COMMON_DEPEND}
"
DEPEND="
${COMMON_DEPEND}
"
src_install() {
dosbin "${OUT}"/bootstat
dosbin bootstat_archive
dosbin bootstat_get_last
dobin bootstat_summary
dolib.so "${OUT}"/lib/libbootstat.so
insinto /usr/include/metrics
doins bootstat.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/libbootstat_unittests"
}