blob: 4f146d0422c73816d94eae9ef34c68a3e18da7ce [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6f9011123f3656c45bb34148673aa110a22326b3"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "b1f4ad4ab3cbb07f7d6d2756b7c06a950376ea88" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_USE_VCSID="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk biod .gn"
PLATFORM_SUBDIR="biod/biod_proxy"
inherit cros-workon platform
DESCRIPTION="DBus Proxy Library for Biometrics Daemon for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/biod/README.md"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND=""
DEPEND="
chromeos-base/libbrillo:=
chromeos-base/system_api:=
"
src_install() {
dolib.so "${OUT}"/lib/libbiod_proxy.so
insinto /usr/include/biod/biod_proxy/
doins ./*.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/biod_proxy_test_runner"
}