blob: c54a52be518ec9c5fabe3fb3a123a9e2d4ce7a77 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d27dfb81bc87df4db16849f5da1b96f1cf5cd10b"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "c4ab24982f8916bc61640a3912b5c1d0337b758f" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_SUBDIR="shill/dbus/client"
inherit cros-workon platform
DESCRIPTION="Shill DBus client interface library"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/HEAD/shill/dbus/client"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND="chromeos-base/shill-client:="
RDEPEND=""
src_install() {
# Install libshill-dbus-client library.
insinto "/usr/$(get_libdir)/pkgconfig"
local v="$(libchrome_ver)"
./preinstall.sh "${OUT}" "${v}"
dolib.so "${OUT}/lib/libshill-dbus-client.so"
doins "${OUT}/lib/libshill-dbus-client.pc"
# Install header files from libshill-dbus-client.
insinto /usr/include/shill/dbus/client
doins ./*.h
}
platform_pkg_test() {
platform_test "run" "${OUT}/libshill-dbus-client_test"
}