blob: 59b3a9f151605931c25ae3509a475b9232ad277f [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="d27dfb81bc87df4db16849f5da1b96f1cf5cd10b"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "c4ab24982f8916bc61640a3912b5c1d0337b758f" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_SUBTREE="common-mk shill .gn"
PLATFORM_NATIVE_TEST="yes"
PLATFORM_SUBDIR="shill/client"
inherit cros-workon platform
DESCRIPTION="Shill DBus client library for Chromium OS"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/shill/"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="cros_host"
RDEPEND="
!<chromeos-base/shill-0.0.2
"
BDEPEND="
chromeos-base/chromeos-dbus-bindings:=
"
src_install() {
# Install DBus client library.
platform_install_dbus_client_lib "shill"
}