blob: 98a8f8f9b6fdd81547b1cacd43c3c66d85d5e02b [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="f34cf3a06f7b17b7829185630d886a5d9d3f0e75"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "446ac148c9c5710eb395d8c044f4e44b8bf4361a" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD=1
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk libipp .gn"
PLATFORM_SUBDIR="libipp"
inherit cros-workon platform
DESCRIPTION="The library for building and parsing IPP (Internet Printing Protocol) frames."
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/libipp/"
LICENSE="BSD-Google"
KEYWORDS="*"
src_install() {
dolib.so "${OUT}/lib/libipp.so"
insinto "/usr/$(get_libdir)/pkgconfig"
doins libipp.pc
insinto "/usr/include/chromeos/libipp"
doins ipp.h ipp_attribute.h ipp_base.h ipp_collections.h ipp_enums.h \
ipp_export.h ipp_operations.h ipp_package.h
# Install fuzzer
platform_fuzzer_install "${S}"/OWNERS "${OUT}"/libipp_fuzzer
}
platform_pkg_test() {
platform_test "run" "${OUT}/libipp_test"
}