blob: f03a11ea412f2d05b88f24b989bc07c98640b392 [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="6f9011123f3656c45bb34148673aa110a22326b3"
CROS_WORKON_TREE=("791c6808b4f4f5f1c484108d66ff958d65f8f1e3" "ac2c9f71de71bb13b6d64a1245a8ea072da49f28" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_INCREMENTAL_BUILD="1"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk arc/container/appfuse .gn"
PLATFORM_SUBDIR="arc/container/appfuse"
inherit cros-workon platform user
DESCRIPTION="D-Bus service to provide ARC Appfuse"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/arc/container/appfuse"
LICENSE="BSD-Google"
KEYWORDS="*"
RDEPEND="
sys-apps/dbus:=
sys-fs/fuse:=
"
DEPEND="${RDEPEND}
chromeos-base/system_api:=
"
BDEPEND="
virtual/pkgconfig
"
src_install() {
platform_install
}
pkg_preinst() {
enewuser "arc-appfuse-provider"
enewgroup "arc-appfuse-provider"
}
platform_pkg_test() {
platform test_all
}