blob: a9652744c272054c6b398a583d4adfe5c3ca29ad [file] [log] [blame]
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.7.9999
#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="An efficient packed Unicode text type"
HOMEPAGE="https://github.com/bos/text"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="*"
IUSE="test"
RESTRICT=test # break cyclic dependencies
RDEPEND="dev-haskell/binary:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( >=dev-haskell/hunit-1.2
>=dev-haskell/quickcheck-2.7
dev-haskell/quickcheck-unicode
dev-haskell/random
>=dev-haskell/test-framework-0.4
>=dev-haskell/test-framework-hunit-0.2
>=dev-haskell/test-framework-quickcheck2-0.2 )
"
src_configure() {
haskell-cabal_src_configure \
--flag=-developer
}