blob: 8ad12973c1b202a527ad82cd7556ff7d52d55fd2 [file] [log] [blame]
# Copyright 2019 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
# This ebuild only cares about its own FILESDIR and ebuild file, so it tracks
# the canonical empty project.
CROS_WORKON_PROJECT="chromiumos/infra/build/empty-project"
CROS_WORKON_LOCALNAME="empty-project"
inherit appid cros-unibuild udev cros-workon
DESCRIPTION="Drallion board-specific ebuild that pulls in necessary ebuilds as
dependencies or portage actions."
LICENSE="BSD-Google"
KEYWORDS="-* ~amd64 ~x86"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND=""
DEPEND="
${RDEPEND}
chromeos-base/chromeos-config:=
"
src_install() {
doappid "{ED3A4869-C380-4F79-A190-027C3E879357}" "CHROMEBOOK"
# Intall a rule tagging keyboard as having updated layout
udev_dorules "${FILESDIR}/81-drallion-keyboard.rules"
unibuild_install_audio_files
unibuild_install_thermal_files
}