| # |
| # Copyright 2022 Google LLC |
| # |
| # This program is free software; you can redistribute it and/or |
| # modify it under the terms of the GNU General Public License |
| # version 2 as published by the Free Software Foundation. |
| # |
| # This program is distributed in the hope that it will be useful, |
| # but WITHOUT ANY WARRANTY; without even the implied warranty of |
| # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
| # GNU General Public License for more details. |
| # |
| |
| EAPI=7 |
| |
| inherit udev |
| |
| DESCRIPTION="Microsoft Azure Linux Agent (waagent)" |
| HOMEPAGE="https://github.com/Azure/WALinuxAgent" |
| SRC_URI="https://github.com/Azure/WALinuxAgent/archive/${PV}.tar.gz -> ${P}.tar.gz" |
| |
| LICENSE="Apache-2.0 BSD ZLIB" |
| KEYWORDS="*" |
| SLOT="0" |
| IUSE="" |
| |
| S=${WORKDIR}/WALinuxAgent-${PV} |
| |
| src_install() { |
| udev_dorules "${S}"/config/66-azure-storage.rules |
| } |