blob: f92d6105cbe4f3e2d485ab58a2c97a6226288ffc [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE="kernelnext"
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
chromeos-base/rmi4utils
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{E9E5C8F0-C30C-190F-CA75-D6184C3FEED6}" "CHROMEBOOK"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Install audio configs.
if use kernelnext; then
local audio_config_dir="${FILESDIR}/kernelnext-audio-config"
else
local audio_config_dir="${FILESDIR}/audio-config"
fi
install_audio_configs setzer "${audio_config_dir}"
exeinto /usr/share/cros
doexe "${FILESDIR}"/oemdata.sh
}