blob: 732fc6e38963afcfa78bbf0aa65ebfe0f3fd0b12 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE="kernelnext"
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{00599913-5741-F624-6375-E732C4602915}" "CHROMEBOOK"
# Install audio configs.
if use kernelnext; then
local audio_config_dir="${FILESDIR}/kernelnext-audio-config"
else
local audio_config_dir="${FILESDIR}/audio-config"
fi
install_audio_configs reks "${audio_config_dir}"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
}